BitVectors are now cached to lower memory utilization.
Instructions have reference semantics.
Details
Details
- Reviewers
courbet - Commits
- rG32d384c0200f: [llvm-exegesis][NFC] internal changes
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
llvm/tools/llvm-exegesis/lib/CodeTemplate.cpp | ||
---|---|---|
17–18 | Let's take Instr by pointer to avoid potentially binding to temporaries. | |
llvm/tools/llvm-exegesis/lib/MCInstrDescView.cpp | ||
86 | push_back(make_unique) ? I don't think there's a good reason to new here. | |
llvm/tools/llvm-exegesis/lib/MCInstrDescView.h | ||
97 | The name is a bit misleading. To me, an XXXBitVector is a BitVector. BitVectorCache would be better I think. | |
98 | Doc ? This is not obvious. | |
101 | SmallVector<T, 0> ? Why not std::vector ? | |
109–118 | can this be private ? | |
122 | Move this to the top ? |
Let's take Instr by pointer to avoid potentially binding to temporaries.