Removed the PPRegionSetTy typedef because it is only used 3 times, and
obscures code more than it helps.
Renamed SharedParsedRegionsStorage to ThreadSafeParsedRegions, because
that better reflects the reason for this type to exist.
Replaced the copyTo() method that had an out parameter with a getter.
Renamed the merge() method to addParsedRegions().
Renamed ParsedSrcLocationsTracker::ParsedRegions to
ParsedRegionsSnapshot, which better reflects its role.