Page MenuHomePhabricator

[GWP-ASan] Remove c++ standard lib dependency.
ClosedPublic

Authored by hctim on Aug 21 2019, 5:03 PM.

Details

Summary

Remove c++ standard library dependency for now for @phosek. They have a
complicated build system that breaks with the fuzzer target here.

Also added a todo to remedy later.

Diff Detail

Repository
rL LLVM

Event Timeline

hctim created this revision.Aug 21 2019, 5:03 PM
Herald added projects: Restricted Project, Restricted Project. · View Herald TranscriptAug 21 2019, 5:03 PM
Herald added subscribers: llvm-commits, Restricted Project, mgorny. · View Herald Transcript
phosek accepted this revision.Aug 21 2019, 5:15 PM

LGTM

This revision is now accepted and ready to land.Aug 21 2019, 5:15 PM
This revision was automatically updated to reflect the committed changes.
pcc added a subscriber: pcc.Aug 21 2019, 5:23 PM
pcc added inline comments.
compiler-rt/lib/gwp_asan/stack_trace_compressor_fuzzer.cpp
12 ↗(On Diff #216527)

Isn't this leaking memory?