Correct comment. Should be 'nnan', not 'nnan and nsz'.
If User is a unary FNeg, I assume isCommutative would be false and this getOperand call will access an operand that doesn't exist.
Bah, these two changes weren't supposed to be a part of this patch. Just an oversight and will update...
Remove unintentional changes. Also fix up a poor naming choice.