Create method optForNaught() testing for -O0 and refactor appropriately.
Details
Details
Diff Detail
Diff Detail
- Repository
- rC Clang
Event Timeline
llvm/include/llvm/IR/Function.h | ||
---|---|---|
594 ↗ | (On Diff #192379) | I understand that we're trying to mimic the existing 'optForSize' naming, but "optForNaught" is not obvious. |
llvm/include/llvm/IR/Function.h | ||
---|---|---|
594 ↗ | (On Diff #192379) | optForNone()? Though I don't feel strongly about it. |
llvm/include/llvm/IR/Function.h | ||
---|---|---|
594 ↗ | (On Diff #192379) | I'm still not reading that as obvious. When I see this in IR, I'm used to seeing the string "optnone", so it makes more sense to me that the query includes that string exactly. If others disagree, I won't block it though. |
llvm/include/llvm/IR/Function.h | ||
---|---|---|
594 ↗ | (On Diff #192379) | In an OCD way, I'm trying to preserve the existing pattern for such methods. 😌 |
Comment Actions
Ok, LGTM...it's just a convenience wrapper, so if anyone feels like the name can be improved, feel free. My vote would still be "isOptNone" or "hasOptNone". If that doesn't match the existing API, then I'd say fix that too: "hasOptSize".