Mostly mechanical, but I've tried to tidy up code where it made sense to
do so.
Details
Diff Detail
- Repository
- rL LLVM
Event Timeline
llvm/lib/IR/Verifier.cpp | ||
---|---|---|
492 ↗ | (On Diff #179673) | I think it would be nicer to call it verifyCall. |
2858 ↗ | (On Diff #179673) | I think that this might be easier to read: if (!Call.getCalledFunction() || Call.getCalledFunction()->getIntrinsicID() != Intrinsic:::experimental_gc_statepoint) |
2872 ↗ | (On Diff #179673) | Similar, use the negation than the nullptr check |
2883 ↗ | (On Diff #179673) | Similar |
4129 ↗ | (On Diff #179673) | Can't this be const? |
4394 ↗ | (On Diff #179673) | Can't this be const? |
4418 ↗ | (On Diff #179673) | Mind switching to static_cast<int>? -Wold-style-cast is .... annoying. |
Thanks for the review, see comments inline.
llvm/lib/IR/Verifier.cpp | ||
---|---|---|
492 ↗ | (On Diff #179673) | I made it CallBase to be consistent with CallInst and InvokeInst, but then I didn't actually make it override the inst visitor method and put it with that list. I've fixed that now. Does this make more sense out of its name? |
2858 ↗ | (On Diff #179673) | Done, but again, these were mechanical changes. I don't know that I can fix all the bad code that happens to be touched. |
4129 ↗ | (On Diff #179673) | It wasn't before my change, so I'd rather not introduce the potential for still more deltas to code. |
4394 ↗ | (On Diff #179673) | See above. |
4418 ↗ | (On Diff #179673) | Not really. We have *so many* of these in the code base that I don't think this is worth doing generally. And moreover, I don't think this is the patch to try and address that. |