[llvm-mca] PR39261: Rename FetchStage to EntryStage.
ClosedPublic

Authored by andreadb on Thu, Nov 8, 9:24 AM.

Details

Summary

This fixes PR39261.

FetchStage is a misnomer. It causes confusion with the frontend fetch stage, which we don't currently simulate.
I decided to rename it into EntryStage mainly because this is meant to be a "source" stage for all pipelines.

Let me know if okay to commit.

Thanks,
Andrea

Diff Detail

Repository
rL LLVM
andreadb created this revision.Thu, Nov 8, 9:24 AM
mattd accepted this revision.Thu, Nov 8, 9:29 AM

LGTM.

tools/llvm-mca/lib/CMakeLists.txt
18 ↗(On Diff #173182)

nit: EntryStage should come before ExecuteStage.

tools/llvm-mca/lib/Context.cpp
24 ↗(On Diff #173182)

nit: EntryStage should come before ExecuteStage.

This revision is now accepted and ready to land.Thu, Nov 8, 9:29 AM

Thanks Matt, I will apply the suggested changes and then commit.

Cheers

This revision was automatically updated to reflect the committed changes.