The checksums had already been placed in the IR, this patch allows
MCCodeView to actually write it out to an MCStreamer.
Details
Diff Detail
- Build Status
Buildable 9641 Build 9641: arc lint + arc unit
Event Timeline
Try to be more careful so as not to submit testing code / comments etc in uploaded patches. Reasons like this are why I prefer using a debugger instead of printf debugging :)
llvm/include/llvm/IR/DebugInfoMetadata.h | ||
---|---|---|
476–481 ↗ | (On Diff #114116) | If you're going to make it an enum class, then it doesn't need the CSK prefix in the name, since you have to write ChecksumKind anyway. I wouldn't suggest churning the code to change the names everywhere it's used, so instead maybe just leave this as a regular enum. It's already scoped to DIFile anyway, so there's no risk of namespace pollution. |
llvm/include/llvm/MC/MCCodeView.h | ||
297–302 | Any reason this isn't just: struct FileInfo { StringRef Name; StringRef Checksum; ChecksumKind Kind; }; SmallVector<FileInfo> Files; having a StringMap seems unnecessary if we're already iterating a linear container anyway | |
llvm/lib/DebugInfo/CodeView/DebugChecksumsSubsection.cpp | ||
53 ↗ | (On Diff #114116) | Delete |
llvm/lib/DebugInfo/CodeView/DebugStringTableSubsection.cpp | ||
32 ↗ | (On Diff #114116) | Delete |
38 ↗ | (On Diff #114116) | Delete |
44 ↗ | (On Diff #114116) | Delete |
llvm/lib/MC/MCCodeView.cpp | ||
188–200 | What is this? A bunch of code commented out, and then emitting a bunch of magic numbers? | |
llvm/tools/llvm-readobj/COFFDumper.cpp | ||
927 ↗ | (On Diff #114116) | Delete |
929 ↗ | (On Diff #114116) | Delete |
1088 ↗ | (On Diff #114116) | Delete |
1090 ↗ | (On Diff #114116) | Delete |
llvm/lib/MC/MCCodeView.cpp | ||
---|---|---|
415–417 | We shouldn't assume all DIFiles have MD5 checksums, we'll need some way to know the filechecksum table offset. We should probably implement this FIXME: // FIXME: We should store the string table offset of the filename, rather than // the filename itself for efficiency. Filename = addToStringTable(Filename); Filenames[Idx] = Filename; We should do that by making FIlenames a vector of two integers: the offset of the file in the file checksum table, and the offset of the filename in the string table. All the places where we do 8 * (FileId - 1) we would rewrite to use Filenames[FileId - 1].ChecksumTableOffset. |
llvm/include/llvm/MC/MCCodeView.h | ||
---|---|---|
283 | remove | |
296 | Just one comment says: Array storing file information. Each tuple contains the string table offset, a symbol representing the file table offset, and a set flag. | |
301 | remove | |
llvm/lib/CodeGen/AsmPrinter/CodeViewDebug.cpp | ||
701 | remove this comment | |
703 | remove junk here too | |
llvm/lib/DebugInfo/CodeView/DebugChecksumsSubsection.cpp | ||
53 ↗ | (On Diff #114469) | remove |
llvm/lib/DebugInfo/CodeView/DebugStringTableSubsection.cpp | ||
32 ↗ | (On Diff #114469) | remove |
39 ↗ | (On Diff #114469) | remove |
45 ↗ | (On Diff #114469) | remove |
llvm/lib/MC/MCCodeView.cpp | ||
---|---|---|
49 | remove | |
60 | remove comment | |
131 | combine this all into one line | |
132 | Don't reassign to S and just directly use Ret.first | |
146 | add a comment explaining this function | |
147 | remove | |
153 | remove spaces here | |
159 | remove these | |
165 | +=4 for the string table offset | |
168 | +1 for size, +1 for kind, +2 to align (maybe just replace that with alignTo for clarity) | |
171 | remove logging, more comments to explain offset | |
174 | add comment explaining that, since the checksum section has been emitted, we can assume the offsets have been finalized so we can assign them. | |
183 | update this comment | |
189 | remove these | |
199 | yes remove this | |
203 | add comment to explain, how it needs to use a MCFixup provided by EmitValueImpl | |
215 | remove | |
218 | create a temporary symbol to hold the offset once it is calculated | |
225 | remove | |
240 | a | |
372 | r | |
415 | change this comment | |
llvm/lib/MC/MCObjectStreamer.cpp | ||
144 ↗ | (On Diff #114469) | r |
llvm/lib/MC/MCParser/AsmParser.cpp | ||
3455 | should be lower case for consistency | |
llvm/lib/MC/WinCOFFObjectWriter.cpp | ||
725 ↗ | (On Diff #114469) | r |
llvm/tools/llvm-readobj/COFFDumper.cpp | ||
910 ↗ | (On Diff #114469) | r these |
1020 ↗ | (On Diff #114469) | r |
1106 ↗ | (On Diff #114469) | not needed |
Make this entire thing easier to follow and understand.
llvm/lib/MC/MCCodeView.cpp | ||
---|---|---|
57 | This is confusing to read, make it more intuitive |
Why do we have to add placeholders for the checksum offsets? Aren't they just added in order, one after another?
Actually, the implementation of addFile hasn't assumed it is done in order, and you can actually add random fileNo's whenever you want. Therefore, we shouldn't assume they are always done in order, and we should allow for the case where we don't yet know the checksum offset.
llvm/include/llvm/IR/DebugInfoMetadata.h | ||
---|---|---|
476–481 ↗ | (On Diff #114116) | Unfortunately I need the actual enum values to correspond exactly to the checksum types flag integer values actually present in the codeview section, hence the strongly typed enum class. This is important because I will now be emitting the ChecksumKind as assembly directives as well as directly into the binary. |
llvm/include/llvm/MC/MCCodeView.h | ||
297–302 | Yes, combined all this info into one vector. It's still useful to have a StringMap because we want to check if a filename is already used before making a new entry. |
llvm/lib/CodeGen/AsmPrinter/CodeViewDebug.cpp | ||
---|---|---|
685 | Update this FIXME to say that we do provide checksum file info, and what VS uses this for. |
llvm/lib/MC/MCCodeView.cpp | ||
---|---|---|
161 | I don't think you want to do this, this leaks the internal MCSymbol (file1, etc) to the assembler. Nothing in the assembly defines file1, so the assembly isn't very readable. | |
llvm/test/DebugInfo/COFF/inlining.ll | ||
52 ↗ | (On Diff #115274) | What I had in mind was that we'd add a directive like .cv_filechecksum_offset <fileid> and MCCodeView.cpp would internally implement it without leaking any labels to the caller. We could use a label difference of two symbols to implement the offset computation, but any symbols shouldn't leak out to the assembler. |
llvm/include/llvm/IR/DebugInfoMetadata.h | ||
---|---|---|
476–481 ↗ | (On Diff #114116) | If you need the enums to have specific values, e.g. because those values end up in the object file (hard to tell here but I think that's what you are saying), you should set the enum values explicitly. This documents the exact values you need (even if they happen to be sequential at the moment). Making it an enum class doesn't get you that. |
llvm/lib/IR/DebugInfoMetadata.cpp | ||
357 ↗ | (On Diff #115274) | If you require exact correspondence between an enum and some array of strings, we usually do that with a .def file and macros. See for example Dwarf.def. As it is, the association between this array and the ChecksumKind values is implied rather than explicit. Safer to be explicit. |
llvm/lib/MC/MCCodeView.cpp | ||
---|---|---|
67 | Use MCContext::createTempSymbol to make sure these don't show up in the .obj symbol table. |
llvm/include/llvm/IR/DebugInfoMetadata.h | ||
---|---|---|
476–481 ↗ | (On Diff #114116) | Remove enum class to explicitly define values. |
llvm/lib/IR/DebugInfoMetadata.cpp | ||
357 ↗ | (On Diff #115274) | Okay this should probably be addressed in another patch as this patch did not introduce the array. |
llvm/lib/MC/MCCodeView.cpp | ||
161 | Instead of emitting the symbol, we will emit the .cv_filechecksumoffset <fileno> directive. |
A few minor commentary points; nothing huge. I've been looking at this mainly with the thought of having to do something similar for DWARF 5 eventually, but it seems likely there won't be a lot to leverage as CodeView and DWARF appear to associate the hashes with files pretty differently. Oh well.
llvm/include/llvm/IR/DebugInfoMetadata.h | ||
---|---|---|
476–481 ↗ | (On Diff #114116) | And maybe a comment that these end up in the object file, so some well-meaning person doesn't come a long later and remove the "unnecessary" explicit values. |
llvm/include/llvm/MC/MCStreamer.h | ||
735 | As long as you're changing the comment anyway, please remove the \brief. | |
777 | Remove \brief. |
llvm/test/DebugInfo/COFF/inlining.ll | ||
---|---|---|
52 ↗ | (On Diff #115274) | implemented as such |
Thanks, looks good!
llvm/include/llvm/MC/MCCodeView.h | ||
---|---|---|
299–300 | Generally, if the comment describing the variable doesn't fit on one line, consider moving it before the variable. Then we won't end up with this awkard split after the *. |
remove