This is another step toward improving fca support. This unpack load of array in a series of load to array's elements.
Why can't we simply call LI.getName() wherever it is required rather than maintaining the variable "Name"?
Same here. Do we really need to maintain NumElements? Can we simply call ST->getNumElements() instead?
I think these could be written better as:
SmallString<16> LoadName = LI->getName() + ".unpack";