Add possiblity to pass name for the allocation of the private copy
as follow up to D155882
Details
Details
- Reviewers
razvanlupusoru vzakhari
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
Comment Actions
This patch is not what I had in mind when I made the name suggestion. Namely, I was thinking the init region would take an additional argument specifying the name - and this would be related to the original variable name. This way a recipe could be reused, but the fir.alloca operations could expand to proper name during materialization.
flang/lib/Lower/OpenACC.cpp | ||
---|---|---|
1000 | I expected the name to be extracted from original variable name! This name is not necessarily useful when debugging. |
Comment Actions
I see your point but I don't think we can pass a ssa value for the name of the fir.alloca's name. What we can probably do is just leave the init region as is. The materialization should be able to gather any alloca and update them with appropriate name if desired.
I expected the name to be extracted from original variable name! This name is not necessarily useful when debugging.