Currently, ROCDL::GridDim*Op is being translated to __ockl_get_global_size, however
to match the meaning of gpu.grid_dim it should instead be translated to
__ockl_get_num_groups. This change would also make it agree with the meaning
of gridDimx.* in HIP, see:
https://github.com/ROCm-Developer-Tools/hipamd/blob/develop/include/hip/amd_detail/amd_hip_runtime.h#L257
Difference between the functions:
__ockl_get_global_size = blockDim * numBlocks __ockl_get_num_groups = numBlocks