This commit does a few minor NFC cleanups:
- A variable was called "Atom", probably trying to claim it was an AtomType.
This was incorrect, it is actually a FormValue.
- LLVM provides a zip_equal to express the intent of asserting ranges with the
same size. We change the lookup method to use that.
- The use of tuples made the code slightly difficult to follow, as such we
unpack the tuple with structure binding to improve readability.
Depends on D152157