They had previously not followed the best practices; I must have
commited these in a rush. In particular, they used hard-coded SSA names
instead of patterns. This patch changes that, uses CHECK-DAG more
instead of CHECK-NEXT, and makes all function names unique.
Details
Details
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
Comment Actions
I realized that my new names weren't accurate: both functions can yield argument or target materializations depending on which ops are converted, so it does not make sense to have target or source in their names. Instead, I named them based on the (original) function signature.