The goal is to separate collecting items for post-processing and processing them.
Post processing also outlined as dedicated method.
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
llvm/lib/Transforms/Vectorize/SLPVectorizer.cpp | ||
---|---|---|
11807–11808 | It can be merged: if (auto *Inst = dyn_cast<Instruction>(Op); Inst && !R.isDeleted(Inst)) |
llvm/lib/Transforms/Vectorize/SLPVectorizer.cpp | ||
---|---|---|
11807–11808 | I'll make this cleanup in the main patch during outlining. Is that okay with you? |
llvm/lib/Transforms/Vectorize/SLPVectorizer.cpp | ||
---|---|---|
11807–11808 | Can you outline this code in this patch? |
llvm/include/llvm/Transforms/Vectorize/SLPVectorizer.h | ||
---|---|---|
128 | Nit: This function does the actual work, so we should probably use different names for this and for the one below. Perhaps vectorizeRootInstructionImpl ? |
llvm/include/llvm/Transforms/Vectorize/SLPVectorizer.h | ||
---|---|---|
128 | To be honest I'm not a big fan of such naming for methods (unless it really necessary). |
llvm/include/llvm/Transforms/Vectorize/SLPVectorizer.h | ||
---|---|---|
128 | Well, using the same function name is fine as long as they do the exact same thing, but in this case the caller also dealing with the postponed values. Yeah, I prefer more descriptive names too than *Impl, but in this case I can't think of anything better. Anyway, feel free to keep the same name. |
llvm/include/llvm/Transforms/Vectorize/SLPVectorizer.h | ||
---|---|---|
128 | Changing the name to vectorizeHorReduction would probably fit better. |
Nit: This function does the actual work, so we should probably use different names for this and for the one below. Perhaps vectorizeRootInstructionImpl ?