Refactor ConnectToRemote() to improve readability and make future
changes easier:
- Replace static buffers with std::string.
- When handling errors, prefer reporting the actual error over dumb 'connection status is not success'.
- Move host/port parsing directly into reverse_connection condition that is its only user, and simplify it to make its purpose (verifying that a valid port is provided) clear.
maybe replace with llvm::errs(), while you're in there?