Call ABI::AugmentRegisterInfo() once with a vector of all defined
registers rather than calling it for every individual register. Move
and rename RemoteRegisterInfo from gdb-remote to
DynamicRegisterInfo::Register, and use this class when augmenting
registers.
Details
Diff Detail
Event Timeline
I like everything except the class name. :)
I don't think it makes sense in the new location, and ideally I'd like to also use this for other plugins in the future (so that e.g. core file plugins don't have to excruciatingly list everything). Maybe we could move it into the the DynamicRegisterInfo class (as the intended use is to convert it to that eventually), and give it some generic name like Register or Descriptor or RegisterDescriptor ?
lldb/include/lldb/Target/DynamicRegisterInfo.h | ||
---|---|---|
96–98 | What's up with this? |
lldb/include/lldb/Target/DynamicRegisterInfo.h | ||
---|---|---|
96–98 | Probably leftover from the previous version. I need to double-check if no other commit requires that. |
Move/rename RemoteRegisterInfo to DynamicRegisterInfo::Register. Remove leftover DRI changes.
What's up with this?