Adds a method called pop_back_n to SmallVector.
This is more readable and less error prone than the alternatives of using
Vector.resize(Vector.size() - N); Vector.erase(Vector.end() - N, Vector.end()); for (unsigned I = 0;I<N;++I) Vector.pop_back();
clang-tidy: warning: invalid case style for function 'pop_back_n' [readability-identifier-naming]
not useful