This renames Worklist.AddDeferred() to Worklist.add() and Worklist.Add() to Worklist.push(). The intention here is that Worklist.add() should be the go-to method for explicit worklist management, while the raw Worklist.push() is mostly for InstCombine internals. I will then migrate uses of Worklist.push() to Worklist.add() in followup changes.
Also happy to switch this to other names if these aren't good.
As suggested by @spatel on D73411 I'm also changing the remaining method names to lowercase first character, in line with current coding standards.