This now matches the name of the class, but also avoids confusion with a
target-specific MCELFStreamer.
Details
- Reviewers
asb
Diff Detail
- Repository
- rG LLVM Github Monorepo
- Build Status
Buildable 31831 Build 31830: arc lint + arc unit
Event Timeline
I think this is less confusing, but there's more to be gained by having a similar naming scheme to the other backends which right now all use FooELFStreamer.{cpp,h}.
I you feel strongly about this change, I'd consider making it for all in-tree backends.
FooELFStreamer.cpp is not a target streamer but an MCELFStreamer. Generally the target streamers live in FooTargetStreamer.cpp. For example, MipsELFStreamer vs MipsTargetELFStreamer. At least that's my understanding, and this patch was motivated by wanting a RISCV-specific MCELFStreamer in our fork, which by that convention should be in RISCVELFStreamer.cpp.
Hm, actually, looking more closely, there seems to be inconsistency. Some backends use FooELFStreamer.cpp for an MCELFStreamer, and others for a ELF-specific target streamer. Some, like AArch64, even put both in the same file, so if you don't like this patch, I suppose the recommendation would be to do that?