This adds ConstantRange::full(BitWidth) and ConstantRange::empty(BitWidth) named constructors as more readable alternatives to the current ConstantRange(BitWidth, /* full */ false) and similar. Additionally private full() and empty() member functions are added which return a full/empty range with the same bit width -- these are commonly needed inside ConstantRange.cpp.
I've also made the IsFullSet argument in the ConstantRange(BitWidth, IsFullSet) constructor mandatory, though I could drop that part if there is a BC concern here.