Kernel ASan is basically ASan with a few specific settings, but has a
seperate front-end flag. Provide a helper that checks for both, so new
comitters like myself are less likely to forget the Kernel variant.
Sorry to bike-shed, but this seems a bit hard to read. How about: 'hasAnyASan'?
I find the current code more readable than with this change.