Use more descriptive name for the method qualifiers getter.
This change was suggested in https://reviews.llvm.org/D56066?id=179477#inline-496961
Paths
| Differential D56792
Rename getTypeQualifiers to getMethodQualifiers ClosedPublic Authored by Anastasia on Jan 16 2019, 9:14 AM.
Details Summary Use more descriptive name for the method qualifiers getter. This change was suggested in https://reviews.llvm.org/D56066?id=179477#inline-496961
Diff Detail Event TimelineComment Actions There isn't really a standard name for this; in the absence of such a name, this seems as good as anything. This revision is now accepted and ready to land.Jan 24 2019, 6:41 PM Closed by commit rL352349: Rename getTypeQualifiers to getMethodQualifiers. (authored by stulova). · Explain WhyJan 28 2019, 3:38 AM This revision was automatically updated to reflect the committed changes.
Revision Contents
Diff 182066 include/clang/AST/CanonicalType.h
include/clang/AST/DeclCXX.h
include/clang/AST/Type.h
lib/AST/ASTContext.cpp
lib/AST/ASTDumper.cpp
lib/AST/ASTStructuralEquivalence.cpp
lib/AST/DeclCXX.cpp
lib/AST/ItaniumMangle.cpp
lib/AST/MicrosoftMangle.cpp
lib/AST/TypePrinter.cpp
lib/AST/VTableBuilder.cpp
lib/CodeGen/CGCall.cpp
lib/Index/USRGeneration.cpp
lib/Parse/ParseCXXInlineMethods.cpp
lib/Sema/SemaCodeComplete.cpp
lib/Sema/SemaDecl.cpp
lib/Sema/SemaDeclCXX.cpp
lib/Sema/SemaOverload.cpp
lib/Sema/SemaTemplateDeduction.cpp
lib/Sema/SemaTemplateInstantiateDecl.cpp
lib/Sema/SemaType.cpp
lib/Serialization/ASTWriter.cpp
tools/libclang/CIndex.cpp
|