Use more descriptive name for the method qualifiers getter.
This change was suggested in https://reviews.llvm.org/D56066?id=179477#inline-496961
Paths
| Differential D56792
Rename getTypeQualifiers to getMethodQualifiers ClosedPublic Authored by Anastasia on Jan 16 2019, 9:14 AM.
Details Summary Use more descriptive name for the method qualifiers getter. This change was suggested in https://reviews.llvm.org/D56066?id=179477#inline-496961
Diff Detail
Event TimelineComment Actions There isn't really a standard name for this; in the absence of such a name, this seems as good as anything. This revision is now accepted and ready to land.Jan 24 2019, 6:41 PM Closed by commit rL352349: Rename getTypeQualifiers to getMethodQualifiers. (authored by stulova). · Explain WhyJan 28 2019, 3:38 AM This revision was automatically updated to reflect the committed changes.
Revision Contents
Diff 183821 cfe/trunk/include/clang/AST/CanonicalType.h
cfe/trunk/include/clang/AST/DeclCXX.h
cfe/trunk/include/clang/AST/Type.h
cfe/trunk/lib/AST/ASTContext.cpp
cfe/trunk/lib/AST/ASTStructuralEquivalence.cpp
cfe/trunk/lib/AST/DeclCXX.cpp
cfe/trunk/lib/AST/ItaniumMangle.cpp
cfe/trunk/lib/AST/MicrosoftMangle.cpp
cfe/trunk/lib/AST/TypePrinter.cpp
cfe/trunk/lib/AST/VTableBuilder.cpp
cfe/trunk/lib/CodeGen/CGCall.cpp
cfe/trunk/lib/Index/USRGeneration.cpp
cfe/trunk/lib/Parse/ParseCXXInlineMethods.cpp
cfe/trunk/lib/Sema/SemaCodeComplete.cpp
cfe/trunk/lib/Sema/SemaDecl.cpp
cfe/trunk/lib/Sema/SemaDeclCXX.cpp
cfe/trunk/lib/Sema/SemaOverload.cpp
cfe/trunk/lib/Sema/SemaTemplateDeduction.cpp
cfe/trunk/lib/Sema/SemaTemplateInstantiateDecl.cpp
cfe/trunk/lib/Sema/SemaType.cpp
cfe/trunk/lib/Serialization/ASTWriter.cpp
cfe/trunk/tools/libclang/CIndex.cpp
|