Dropping the names of invokes will lead to loss
of information possibly leading to inlining of
cold calls unnecessarily.
CallSite(&Inst).getCalledFunction() might be easier to read here.
apply suggestion from @vsk
(Looks reasonable to me. I haven't really touched this code, so it'd help if another review could +1 the change.)