There is currently too much redundancy in the class/variable/* names in Scudo:
- we are in the namespace __scudo, so there is no point in having something named ScudoX to end up with a final name of __scudo::ScudoX;
- there are a lot of types/* that have Allocator in the name, given that Scudo is an allocator I figure this doubles up as well.
So change a bunch of the Scudo names to make them shorter, less redundant, and
overall simpler. They should still be pretty self explaining (or at least it
looks so to me).
The TSD part will be done in another CL (eg __scudo::ScudoTSD).
I'd keep PrimaryAllocator and SecondaryAllocator, PrimaryT is just puzzling to see in the code.