Page MenuHomePhabricator

[OMPT] Rename ompt_wait_id to omp_wait_id

Authored by protze.joachim on May 7 2018, 9:28 AM.



Similar as in D43568, this patch renames ompt_wait_id* to omp_wait_id*. This renaming was introduced in OpenMP TR6.

Since this patch might bring similar trouble to tool writers as D43568, I would submit both patches at the same time.

Diff Detail

Event Timeline

protze.joachim created this revision.May 7 2018, 9:28 AM
Hahnfeld accepted this revision.May 8 2018, 12:26 AM

Sounds good if that's the direction of the spec. It was clear that the implementation of OMPT might change based on newer Technical Reports.


You should add another space before /* here and in many more places below

This revision is now accepted and ready to land.May 8 2018, 12:26 AM
This revision was automatically updated to reflect the committed changes.