As discussed in https://reviews.llvm.org/D45606, it makes more sense to name the class as SmallVectorMemoryBuffer
Fix up a few comments & then it seems fine.
|1–2 ↗||(On Diff #142538)|
Please fix this comment so it still ends with "-*- C++ -*-==//" - maybe by removing the descriptive text, now that it's a bit redundant.
|46–48 ↗||(On Diff #142538)|
Line wrapping (maybe just drop the indentation and put the "r-value and StringRef." at the end of the previous line.