This type is created on-demand and used as the base type for array
ranges. Since it is "special", its construction did not go through the
createTypeDIE function and so it was never inserted into the accelerator
table, although it clearly belongs there.
I add an explicit addAccelType call to insert it into the table.
Another interesting question is whether we shouldn't rename this to something more unique (_Sizetype ?). As it stands now, if a user has his own sizetype defined, lldb will get confused and will not be able to differentiate the two. Gcc emits this type as "unsigned long", but doing that is a bit trickier for us as we don't want to assume a particular front-end here.