I suggest to add checks to test that we do not produce
output where VA of sections overruns available address space.
Details
Diff Detail
- Repository
- rLLD LLVM Linker
Event Timeline
LGTM with nits.
ELF/Writer.cpp | ||
---|---|---|
2075 | This is templated on ELFT, may as well use it. It might be cleaner to write this as one check |
ELF/Writer.cpp | ||
---|---|---|
2071 | You should have changed the name of this function because it does more than checking section overlaps. |
ELF/Writer.cpp | ||
---|---|---|
2071 | I renamed it to checkSections, it matches the command line option name. Does it sound fine? |
addresses -> address