Right now clang uses "_n" suffix for some user space callbacks and "N" for the matching kernel ones. There's no need for this and it actually breaks kernel build with inline instrumentation. Use the same callback names for user space and the kernel (and also make them consistent with the names GCC uses).
Asan uses "asan_loadN" and "asan_storeN" and hwasan now has "hwasan_loadN" and "hwasan_storeN", so both use "N" and this is consistent as is.
Asan however has "__asan_report_store_n_noabort" (and others based on "kAsanReportErrorTemplate"), which uses "_n", but hwasan doesn't have those as of yet.