|7620 ↗||(On Diff #123884)|
Rename to isFMAddSubOrFMSubAdd?
|7628 ↗||(On Diff #123884)|
Should just return SDValue() here no matter the type. We can't create a X86ISD::SUBADD, there's no such instruction.
|29708 ↗||(On Diff #123884)|
Maybe merge this with isAddSub by passing a bool value to indicate which one you're looking for. Then you just need to factor that bool into the code that detects the FSUB/FADD
|204 ↗||(On Diff #123884)|
There's no such instruction as SUBADD that doesn't include the multiply. So we shouldn't be adding this opcode.
Is this really testing both ways of doing this? There's one from shuffles and one from build_vector.
According to the coverage build bot, the build_vector path of fmaddsub isn't tested today.
|7330 ↗||(On Diff #124128)|
Rename to isAddSubOrSubAdd?
|7333 ↗||(On Diff #124128)|
Call this matchSubAdd instead of isSubAdd.
|29730 ↗||(On Diff #124128)|
This should probably be "ADDSUB, FMADDSUB, or FMSUBADD"