This extends llvm-rc parsing tool by MENU resource (msdn.microsoft.com/en-us/library/windows/desktop/aa381025(v=vs.85).aspx). As for now, MENUEX (msdn.microsoft.com/en-us/library/windows/desktop/aa381023(v=vs.85).aspx) seems unnecessary.
Details
Diff Detail
- Repository
- rL LLVM
Event Timeline
Small bugfixes (compilation problems on gcc and missing newlines at the end of the files).
llvm/tools/llvm-rc/ResourceScriptParser.cpp | ||
---|---|---|
316 | I've never seen this before. Is there a reason to using a comma instead of just putting as a separate statement? | |
320 | do the early continue for better readability, and remove the else block. i.e. while (....) { ...... if (IsMenuItem && isNextTokenKind(Kind::Identifier)) { ..... continue; } ASSIGN_OR_RETURN(CaptionResult, readString()); ....... } | |
323 | doesn't ASSIGN_OR_RETURN go here? | |
344 | can use same early continue pattern here. | |
393 | Sorry this isn't part of this revision, but this should have a better name, like just "createError()" |
llvm/tools/llvm-rc/ResourceScriptParser.cpp | ||
---|---|---|
393 | OK, might be. As this name is scattered around the file, I suggest that I refactor it as soon as all the parser parts are accepted. |
Can you rebase this and the other patches and I'll take another look?
llvm/test/tools/llvm-rc/parser.test | ||
---|---|---|
120 | The same comment re: pipes applies here. |
llvm/tools/llvm-rc/ResourceScriptParser.cpp | ||
---|---|---|
343 | ArrayRef will help here too. |
The same comment re: pipes applies here.