Page MenuHomePhabricator

[mips] Rename getSupportedNanEncoding() to getIEEE754Standard() (NFC)
ClosedPublic

Authored by abeserminji on Aug 17 2017, 4:19 AM.

Details

Summary

As function getSupportedNanEncoding() relies on IEEE 754 Standard, new suggested name is getIEEE754Standard() which is more convenient to use in decision non related to NaN encoding.

Isolated to separate patch on @atanasyan 's suggestion here D35982.

Diff Detail

Repository
rL LLVM

Event Timeline

abeserminji created this revision.Aug 17 2017, 4:19 AM
abeserminji retitled this revision from Rename getSupportedNanEncoding() to getIEEE754Standard() (NFC) to [mips] Rename getSupportedNanEncoding() to getIEEE754Standard() (NFC).Aug 17 2017, 4:24 AM
abeserminji edited the summary of this revision. (Show Details)
abeserminji edited the summary of this revision. (Show Details)
sdardis accepted this revision.Aug 17 2017, 6:30 AM

LGTM with comment addressed.

lib/Driver/ToolChains/Arch/Mips.cpp
328 ↗(On Diff #111490)

"are not in accordance to standard from 2008, it was first introduced in Release 3."

This should read:

"do not conform to the IEEE754-2008 standard. Support for this standard was first introduced in Release 3."

This revision is now accepted and ready to land.Aug 17 2017, 6:30 AM

Comment resolved.

abeserminji marked an inline comment as done.Aug 22 2017, 4:35 AM
This revision was automatically updated to reflect the committed changes.