Details
Diff Detail
- Build Status
Buildable 9116 Build 9116: arc lint + arc unit
Event Timeline
- Moved assignment RemoveFile = nullptr around a bit.
- Added a comment to recreateFileIfCompileCommandChanged.
clangd/ClangdUnitStore.cpp | ||
---|---|---|
45 | I'd argue that having it in the code, rather than declaration makes it more readable. Besides, default ctor of shared_ptr gives us nullptr anyway, so we can also leave it as is and remove the assignments altogether. I've moved =nullptr assignments out of the if/else bodies. Let me know if it still looks ugly. | |
clangd/ClangdUnitStore.h | ||
45–48 | Added a comment. Hopefully makes sense now. |
Addressed review comments.
- Added a test for forceReparse.
- Got rid of a redundant = nullptr assignment.
Done :-)
clangd/ClangdUnitStore.h | ||
---|---|---|
45–48 | This CppFile may still be referenced from the worker threads that store a pending reparse task for this file. Or there may even be an active reparse on a separate thread. |
Not obvious to me what things in there mean.