Fix Android build after r266267
Why is this necessary? stdout is a local variable defined in this scope. Why would the android g++ have problems with this?
Anyway, if you have to avoid using stdout as a name, maybe name it std_out as that better reflects its meaning.
My understanding that NDK toolchain exposes stdout global variable that is caused name collision here.
Judging by the cryptic error message, and the fact that a global variable should not cause an issue, i suspect stdout was a macro in this case...