This is an archive of the discontinued LLVM Phabricator instance.

[libc++][NFC] Rename iterator category checks to make it obvious that they check //only// the iterator category
ClosedPublic

Authored by philnik on May 17 2023, 10:35 AM.

Details

Summary

We plan to add concepts for checking that iterators actually provide what they claim to. This is to avoid people thinking that these type traits actually check the iterator requirements in more detail.

Diff Detail

Event Timeline

philnik created this revision.May 17 2023, 10:35 AM
Herald added a project: Restricted Project. · View Herald TranscriptMay 17 2023, 10:35 AM
Herald added a subscriber: wenlei. · View Herald Transcript
philnik requested review of this revision.May 17 2023, 10:35 AM
Herald added a project: Restricted Project. · View Herald TranscriptMay 17 2023, 10:35 AM
Herald added a reviewer: Restricted Project. · View Herald Transcript

Can you add information in the commit message why this change is needed?

ldionne accepted this revision.May 18 2023, 9:31 AM

LGTM w/ comment.

libcxx/include/__iterator/iterator_traits.h
476

Maybe __libcpp_is_contiguous_iterator instead? It doesn't imply anything about C++17 or whether we check for a specific category/concept.

This revision is now accepted and ready to land.May 18 2023, 9:31 AM
philnik edited the summary of this revision. (Show Details)May 18 2023, 3:35 PM
This revision was automatically updated to reflect the committed changes.
philnik marked an inline comment as done.