Added minor update inside the frem. Fix : #61653
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
llvm/docs/LangRef.rst | ||
---|---|---|
9609 | This doesn't seem to match with what you've added above - is x86 setting errno? |
llvm/docs/LangRef.rst | ||
---|---|---|
9609 | the ‘frem’ instruction is commonly used in the implementation of mathematical functions in the standard C library, known as libm. The libm library provides a wide range of mathematical functions, such as trigonometric functions, logarithmic functions, exponential functions, and more. The implementation of these functions often involves the use of the ‘frem’ instruction to calculate remainders, which are used in various computations. For example, the implementation of the trigonometric function ‘sine’ typically involves computing the remainder of the angle divided by 2π, which can be done using the ‘frem’ instruction. Overall, the ‘frem’ instruction is a fundamental building block for many mathematical functions in libm and is a crucial part of many numerical computations in general. ‘frem’ instruction itself does not set ‘errno’ on x86 systems, but errors can be detected by checking the result of the instruction or examining the floating-point status flags. |
Sorry for the delay in replying to this. I don't think that such implementation details belong in the documentation of the operation.
Is there a particular problem that would have been avoided by adding in this information?
Thanks!
I understand now that the intent behind the issue is that one may need to link libm in order to use frem, which was not obvious to me from the initial change.
I suggested an edit that conveys this more directly. Let me know what you think.
llvm/docs/LangRef.rst | ||
---|---|---|
9589–9596 | Thanks for your patience. I propose the following rewrite for your change (or something to that effect). WDYT? |
llvm/docs/LangRef.rst | ||
---|---|---|
9589–9596 | Seems like I am missing a linefeed after the last line, please add that too :-) |
Thanks for your patience. I propose the following rewrite for your change (or something to that effect). WDYT?