Along the way, setting of errno has been moved out of the internal code.
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
Add a comment explaining why operator delete is not implemented inline and why
we assign them special linkage names.
libc/src/__support/CPP/CMakeLists.txt | ||
---|---|---|
105 | The target names here reflect the header file name. So, I am inclined to keep it as is for the sake of consistency. | |
libc/src/__support/CPP/new.h | ||
72 | Thanks for asking - I have added a comment now explaining that aspect. |
libc/src/__support/CPP/CMakeLists.txt | ||
---|---|---|
105 | Yes, that's actually what I meant, since in this patch, the header new.h defines both new and delete operators, and new.cpp only implements delete operators. It's probably better to rename both the header and the cpp files also. |
libc/src/__support/CPP/CMakeLists.txt | ||
---|---|---|
105 | Ah - we try to keep the header file names in sync with C++ standard header file names: https://eel.is/c++draft/new.syn |
Maybe change the name to new_and_delete or new_delete?