A small number of cleanups and refactors intended to enhance readability in
two passes that deal with s_waitcnt instructions.
Change-Id: Iff58371f659e8648b695868af009c5613de0e213
Paths
| Differential D136677
[AMDGPU] Small cleanups in wait counter code ClosedPublic Authored by stepthomas on Oct 25 2022, 5:51 AM.
Details
Summary A small number of cleanups and refactors intended to enhance readability in Change-Id: Iff58371f659e8648b695868af009c5613de0e213
Diff Detail
Event TimelineComment Actions Note that getScoreLB should always be <= getScoreUB, so code like getScoreLB < getScoreUB can be updated to getScoreRange != 0.
Comment Actions Address review comments Rename isStoreCountWait() -> isStoreCountWaitZero(), use getScoreRange() Comment Actions Thank you for the cleanup! I left some suggestions, but I am also OK with everything as-is
Comment Actions Rebase and address more review comments. Apply a suggested change to setScoreUB() that I'd somehow missed before, This revision is now accepted and ready to land.Oct 28 2022, 2:41 AM This revision was landed with ongoing or failed builds.Oct 28 2022, 3:05 AM Closed by commit rGc8a90316fa75: [AMDGPU] Small cleanups in wait counter code (authored by stepthomas, committed by foad). · Explain Why This revision was automatically updated to reflect the committed changes.
Revision Contents
Diff 471471 llvm/lib/Target/AMDGPU/GCNHazardRecognizer.cpp
llvm/lib/Target/AMDGPU/SIInsertWaitcnts.cpp
|
Not sure about the name. Maybe isWaitStoreCountZero would be better...?