This commit addresses concerns raised in D129497.
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
That's more like it. I personally would rename VAL_nn to something meaningful, but I understand why others don't... ;)
Thanks, looks much better! Could you introduce some more descriptive names for LIT variables?
flang/test/Lower/Intrinsics/transpose_opt.f90 | ||
---|---|---|
24 | You may prefer something like: ! CHECK-DAG: <first check> ! CHECK-NOT: @_FortranATranspose ! CHECK-DAG: <last check> Otherwise, this will only verify that there's no @_FortranATranspose after the final CHECK. More on this idiom here. |
I could, but I really do not want to spend time on this :) I think this is why we have the script for generating the checks - to save us some time :)
flang/test/Lower/Intrinsics/transpose_opt.f90 | ||
---|---|---|
24 | Ah, good catch! I will fix it. I am going to be unavailable for a week, so I am not sure if I will be able to merge it, but I will upload it for review today. |
flang/test/Lower/Intrinsics/transpose_opt.f90 | ||
---|---|---|
24 | Actually, I think it should be okay, since there will be @_FortranATranspose declaration in case of a call to the runtime function. Since all declarations usually follow the user function, having CHECK-NOT: @_FortranATranspose after all the checks should be enough. |
Well, that too (from the script):
The script is designed to make adding checks to a test case fast, it is *not* designed to be authoritative about what constitutes a good test!
More meaningful variable names make reviewing and triaging much easier. And can easily be introduce with sed (or alternatives available in your favorite editor). It really helps when tests are reduced like you did in this patch, too. Anyway, case closed!
You may prefer something like:
Otherwise, this will only verify that there's no @_FortranATranspose after the final CHECK. More on this idiom here.