Unify the output format of raw profiles for hybrid sample and LBR only sample.
Looks like we're changing (begin, end): count to begin-end: count. Curious any restriction on the format, or reason why one is chosen over the other? Is that purely to align with internal raw output from fleet profiler?
nit: show-xx is often used to output xx as extra. how about something like [show-]address-as-offset or use-offset. I'd change the term/variable name from relative address to offset too.
For CS raw profile (!CI.first.empty()), can we still keep the indentation like before for readability? Same for branch below. Otherwise it looks good.