Page MenuHomePhabricator

[flang] Change capitalization for Adjustl/r

Authored by rovka on May 31 2021, 2:44 AM.



Rename the definitions of the character runtime functions Adjustl and
Adjustr (used to be AdjustL and AdjustR respectively, which didn't match
the declarations).

Also add unit tests (and move some of the helpers to the top of the
file, since they're now used in more than one place).

Diff Detail

Event Timeline

rovka created this revision.May 31 2021, 2:44 AM
rovka requested review of this revision.May 31 2021, 2:44 AM
Herald added a project: Restricted Project. · View Herald TranscriptMay 31 2021, 2:44 AM

The names in the API are the right ones.

rovka updated this revision to Diff 349473.Jun 3 2021, 12:55 AM
rovka edited the summary of this revision. (Show Details)

Right, I wasn't sure so I just picked the one that seemed to look more like the rest of the runtime :) Is there a convention somewhere, or is it just that once we committed something to the header we shouldn't change it? In any case, I updated the patch, hope it looks better now.

klausler accepted this revision.Jun 3 2021, 10:42 AM

LGTM; thanks!

This revision is now accepted and ready to land.Jun 3 2021, 10:42 AM
This revision was automatically updated to reflect the committed changes.