Page MenuHomePhabricator

[clangd] Set minimum gRPC version to 1.27
Changes PlannedPublic

Authored by kbobyrev on Jul 21 2020, 4:51 AM.

Details

Reviewers
hokein
Summary

gRPC 1.26 and earlier are affected by bugs preventing remote index from working:

This patch sets minimum version of gRPC to 1.27 when it is installed manually
or via APT on Debian-like Linux distributions.

Related Debian bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=965217

Diff Detail

Unit TestsFailed

TimeTest
9,680 mslinux > libomp.env::Unknown Unit Message ("")
Script: -- : 'RUN: at line 1'; /mnt/disks/ssd0/agent/llvm-project/build/./bin/clang -fopenmp -pthread -fno-experimental-isel -I /mnt/disks/ssd0/agent/llvm-project/openmp/runtime/test -I /mnt/disks/ssd0/agent/llvm-project/build/projects/openmp/runtime/src -L /mnt/disks/ssd0/agent/llvm-project/build/lib -I /mnt/disks/ssd0/agent/llvm-project/openmp/runtime/test/ompt /mnt/disks/ssd0/agent/llvm-project/openmp/runtime/test/env/kmp_set_dispatch_buf.c -o /mnt/disks/ssd0/agent/llvm-project/build/projects/openmp/runtime/test/env/Output/kmp_set_dispatch_buf.c.tmp -lm -latomic
1,650 mslinux > libomp.worksharing/for::Unknown Unit Message ("")
Script: -- : 'RUN: at line 1'; /mnt/disks/ssd0/agent/llvm-project/build/./bin/clang -fopenmp -pthread -fno-experimental-isel -I /mnt/disks/ssd0/agent/llvm-project/openmp/runtime/test -I /mnt/disks/ssd0/agent/llvm-project/build/projects/openmp/runtime/src -L /mnt/disks/ssd0/agent/llvm-project/build/lib -I /mnt/disks/ssd0/agent/llvm-project/openmp/runtime/test/ompt /mnt/disks/ssd0/agent/llvm-project/openmp/runtime/test/worksharing/for/kmp_set_dispatch_buf.c -o /mnt/disks/ssd0/agent/llvm-project/build/projects/openmp/runtime/test/worksharing/for/Output/kmp_set_dispatch_buf.c.tmp -lm -latomic && /mnt/disks/ssd0/agent/llvm-project/build/projects/openmp/runtime/test/worksharing/for/Output/kmp_set_dispatch_buf.c.tmp 7

Event Timeline

kbobyrev created this revision.Jul 21 2020, 4:51 AM
kbobyrev updated this revision to Diff 279497.Jul 21 2020, 5:59 AM

Check gRPC version for system-installed APT package on Debian-like Linux
distros.

Herald added a project: Restricted Project. · View Herald TranscriptJul 21 2020, 5:59 AM
Herald added a subscriber: cfe-commits. · View Herald Transcript
kbobyrev edited the summary of this revision. (Show Details)Jul 21 2020, 6:00 AM

Aww, this might be problematic. Ubuntu has quite old gRPC versions (which are OK though). The newest is 1.26.0 and it's on Groovy (20.10, unreleased yet).

kbobyrev planned changes to this revision.Jul 24 2020, 1:23 AM

Maybe wait for Debian packages to get updated and then whitelist 1.26.0-4 but fail with anything lower than that.

kbobyrev edited the summary of this revision. (Show Details)Jul 30 2020, 8:45 AM
kbobyrev edited reviewers, added: hokein; removed: sammccall.

This patch is not ready for review yet; planned changes: check if the version is between 1.25.0 and 1.26.0-4 and bail out in such cases.