Might be worth making this V.capacity() - V.size() + 1 to make it more precise? While V.capacity() will always be enough, I think (to me at least) that might make the test a bit harder to read, since capacity() may be significantly more than needed.
Thanks for the review! Landed in 3043e5a5c33c4c871f4a1dfd621a8839f9a1f0b3.
Good point. I updated as suggested in the commit.
In the similar case for the InsertN test below, I decided to expand the comment and leave it as V.capacity() since being precise there made it harder to reason about (since there we care about NumToInsert being larger than something).