Makes it a little easier to read objdump's disassembly.
- Group Reviewers
- rG5d26bd3b7553: [lld-macho] Emit indirect symbol table
Semantically blank names are beyond our reach in struct section_64, but class OutputSection is ours and we have the freedom to grant meaningful names. In writeTo() the assignments from members of OutputSection to section_64 will make it clear how the meaningful names map onto the meaningless names.
English style nit.
It's not clear to me that reserved1 is *only* used to point to the indirect symbol table. Its semantics might be section-type-specific. That's why I didn't call it indirectSymtabOffset or something
Aren't they the same thing? Accordingly to Grammarly:
On second thought though it would be more accurate to say that "the indirect symbol table *is* a concatentation"
Ah, I see. OutputSection is very superclassy, so the reserved members are just as generic as for section_64. My suggestion would be better suited to a subclass shared by GotSection, TlvPointerSection, and StubsSection.
While Grammarly is technically correct (as are you), the nit I am picking is a matter of style.
This is the famous passage from Strunk & White's The Elements of Style (do you know it?):
... and your second thought is even better!