- User Since
- Mar 13 2020, 11:31 AM (27 w, 6 d)
In lld/MachO/SyntheticSections.cpp, there are three instances of ...
@thakis, the failure only affects incremental build & test. Everything is good on a clean tree. What do you advise now?
Be sure to remove Flags<[HelpHidden]> from ldd/MachO/Options.td for these.
Tue, Sep 22
- Add overview comments to tests
I only skip 0x when base == 16. My change does nothing to alter the base == 0 case, and GetAutoSenseRadix continues to operate as before.
- revert unnecessary parens in MachHeaderSection::getSize()
- Count instances of LCDylib inside constructor rather than at construction sites
- Elide uninteresting columns from llvm-objdump --all-headers output to reduce length and noise of the lines
- Add tests for all types of LCDylib: self, load, reexport
- Add tests for null-effect of -headerpad_max_install_names when no LCDylibs are present
- Add test for -headerpad N exceeding size of -headerpad_max_install_names
- Fix braino in findLibrary() (consecutive returns: first always shadows second)
- Refine tests to catch the braino
- add testcase for 0X prefix alongside 0x
- resequence diff stack so this can land now
- check args once and save result in Config::searchDylibsFirst
- split some long command lines in lld/test/MachO/link-search-order.s
Mon, Sep 21
- add a test case
I just added the rational to the diff summary.
Sat, Sep 19
Fri, Sep 18
- Remove redundant change to lld/MachO/OutputSegment.cpp
- Final round of cleanups & review-feedback integration
Thu, Sep 17
- add UNWIND_INFO_COMMON_ENCODINGS_MAX
- revise, expand & prune comments
- improve variable names for CU entry folding
- clean-up some ugly special cases by excluding __LD from outputSegments
Sat, Sep 12
- Folding adjacent CU entries requires a vector with monotonically increasing functionAddress, and to get that we must first apply std::sort().
- Abandon passing pageBreak 2nd compare arg via lambda-capture, because it is a fragile technique. It is only by an accident of the implementation that it works on std::lower_bound. It does not work for std::upper_bound, std::binary_search, or std::equal_range.
Fri, Sep 11
- finalize LD,compact_unwind before relocating
Wed, Sep 9
- follow review feedback
Sat, Sep 5
- use %python prefix in test file
- minor cleanups
Do the work in finalize() member rather than getSize() const. Drop mutable from data members. Ahhh! So much nicer!
Wed, Sep 2
- Remove redundant unwind_info_section_header_lsda_entry, and use existing unwind_info_section_header_lsda_index_entry instead.
- Don't cache UnwindInfoSection::isNeeded() result since it is only called once.
- Permute the register save set in order to generate a larger variety of encodings.
- Align generated functions at larger boundary so it works for testing ld64 also.
- Expand the object-file encoding regexp to capture optional personality+lsda
Tue, Sep 1
Improvements & cleanups to validate-unwind-info.py:
- accept input from multiple files or stdin
- fail if any expected categories of input are absent
Mon, Aug 31
Improvements & cleanups to generate-cfi-funcs.py:
- add --functions=N arg
- move some comments into doc strings
- Revise the arg signature for the comparison lambda for std::lower_bound() to emphasize that the 2nd pointer argument is ignored. Rather, we pass the comparand via lambda capture.
Sun, Aug 30
- Correction in lld/MachO/UnwindInfo.h: s/LLD_MACHO_COMPACT_UNWIND_H/LLD_MACHO_UNWIND_INFO_H/
- Move some constant definitions that belong in libunwind/include/mach-o/compact_unwind_encoding.h
- constify all CompactUnwindEntry64*
- simplify level-1 index sentinel address calculation
- pass functionAddressMax via lambda capture rather than via constructed cuEntry
- heed clang-tidy's advice
- Revert to simple llvm-lit test format, since bash is unnecessary
- Rework pageBounds as a simple vector rather than a vector of pairs, and expand associated comments
Sat, Aug 29
Update according to Jez's simple review-feedback items - i.e., everything except the hackiness surrounding __LD,__compact_unwind's anomalies as a MergedOutputSection.
Fri, Aug 28
- Relocate some macro definitions into libunwind/include/mach-o/compact_unwind_encoding.h
- Decouple target word size from the host word size for the compact unwind entry structs
Aug 14 2020
supplement TODO comment
Aug 13 2020
add unittest for new symbol PlatformKind::driverKit
Aug 11 2020
Tighten testcase by imposing sequencing on expected lines
correct some omissions
Add const qualifier to reference arg
Remove spurious change to lld/MachO/CompactUnwind.cpp
add testcase & respond to review feedback
@int3, For tests cases, I did the simple fix of adjusting addresses to accommodate the expansion of the load-command section. Should I expend the effort to generalize via patterns in order to quietly absorb future load-command expansions?