Refactor Succ/Pred maps to have a single map lookup when constructing
children. The preivous desing made sense when used by GraphTraits.
This more closely matches the previous approach in DomTree.
Details
Details
- Reviewers
dblaikie - Commits
- rGfbca317694bf: [CFGDiff] Refactor Succ/Pred maps.
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Unit Tests
Unit Tests
Time | Test | |
---|---|---|
360 ms | linux > Polly.ScopInfo::Unknown Unit Message ("") |
Event Timeline
llvm/include/llvm/Support/CFGDiff.h | ||
---|---|---|
81 | Should this 0 be IsInsert? | |
122–131 | 1 - IsInsert might be more clearly written as !IsInsert or IsInsert == false? (I'd tend towards the ! notation myself, but I understand the == false notation might be a bit more legible/clear/harder-to-miss) | |
148–150 | I think we've probably got a utility for erase+remove in STLExtras.h? |
clang-tidy: warning: invalid case style for function 'erase_value' [readability-identifier-naming]
not useful