Previously we only had a stub document.
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
llvm/docs/CommandGuide/llvm-size.rst | ||
---|---|---|
14 |
Is there a concise term that refers to object files/executables/shared objects/archives collectively? I don't have particular suggestion here. As a reference, FreeBSD size says:
We support Mach-O and PE/COFF so "ELF objects" is not accurate... | |
163 |
The Berkeley format prints more than 1 field, so GNU size refers to them as "totals". GNU size:
FreeBSD size:
| |
178 | Or simply Display the version of this program. as used by other utilities. |
llvm/docs/CommandGuide/llvm-size.rst | ||
---|---|---|
14 | TL;DR - Either we use "binary" (or possibly "archives and binaries"), or we go with the not-always-correct-but-commonly-used term "object file". Let me know if you have a specific preference. So technically, "object files" for ELF refers to all ELF types, not just ET_REL objects. For example, the ELF gABI says:
The FreeBSD spec seems to describe the same principle (note that it doesn't highlight executables separately from relocatable objects). On the other hand, wider usage seems to be "object file" = "relocatable object". Similarly, the terminology used in the PE/COFF file format calls executables "executables" and not objects (which is used for reloctable objects specifically). Mach-O uses the term binary. LLVM code seems to be inconsistent (e.g. the ObjectFile class can represent executables or reloctable objects of all supported formats). We use the term "object files" to refer to any input (except archives) in llvm-symbolizer.rst, and llvm-readobj.rst. In llvm-nm.rst, we use "LLVM bitcode files, object files, and archives". llvm-objcopy uses "objects", so we should use the same terminology throughout the docs for these files. I'm happy to add a specific mention of archives though. I don't have a good way of grouping archives with object files into a single concise term, unless we go with the very imprecise term "binary". | |
178 | I discussed this internally with a colleague and was planning on putting up a patch to change the docs for the other tools to match this version. The reasoning is that everywhere else, we refer to the program by its name e.g. "llvm-size exits with" or "llvm-size reads a file.." rather than "This program exits" etc. Additionally, as this doc isn't part of the executable, referring to the tool as "this program" isn't technically correct. |
Address some review comments. Specifically, reworded the --totals description, added a note about archive inputs, and replaced "object files" with "binaries" etc, to be more correct.
Fix formatting of code blocks, so that the text following them are not considered part of the block.
Is there a concise term that refers to object files/executables/shared objects/archives collectively? I don't have particular suggestion here.
As a reference, FreeBSD size says:
We support Mach-O and PE/COFF so "ELF objects" is not accurate...