Page MenuHomePhabricator

[lldb] Don't use __FUNCTION__ as a file name

Authored by teemperor on Wed, Jul 10, 10:41 PM.



I saw while debugging that we call this file ParseInternal, which is not a very good name for our
fake expression file and also adds this unnecessary link between the way we name this function
and the other source location names we get from the expression parser. This patch is renaming
it to <lldb-expr> which is closer to the way Clang names its buffers, it doesn't depend on the
function name (which changes when I refactor this code) and it's easier to grep for.

Diff Detail


Event Timeline

teemperor created this revision.Wed, Jul 10, 10:41 PM
Herald added a project: Restricted Project. · View Herald TranscriptWed, Jul 10, 10:41 PM
davide accepted this revision.Thu, Jul 11, 7:40 AM

This seems fairly straighforward and I'm in favor of it. We maybe should do the same thing with swift, I haven't checked in a while how we call the file there.
I wouldn't bother adding a test for something so minor.

This revision is now accepted and ready to land.Thu, Jul 11, 7:40 AM
This revision was automatically updated to reflect the committed changes.
Herald added a project: Restricted Project. · View Herald TranscriptThu, Jul 11, 12:27 PM