This is an archive of the discontinued LLVM Phabricator instance.

Rename lldb register enums to contain lldb_ prefix
ClosedPublic

Authored by zturner on Nov 20 2014, 5:24 PM.

Details

Summary

LLDB supports many different register numbering schemes, and these are typically prefixed with an indicator that lets the user know what numbering scheme is used. The gcc numbering scheme is prefixed with gcc, and there are similar ones for dwarf, gdb, and gcc_dwarf. Examples of these registers are gcc_eax_i386, or gcc_dwarf_mm2_x86_64.

LLDB also contains its own internal numbering scheme, but the enum for LLDB's numbering scheme was prefixed differently. This patch updates changes the names of these enums to use the same naming scheme for the enum values as the rest of the register kinds by removing gpr_ and fpu_ prefixes, and instead using lldb_ prefixes for all enum values.

Diff Detail

Event Timeline

zturner updated this revision to Diff 16464.Nov 20 2014, 5:24 PM
zturner retitled this revision from to Rename lldb register enums to contain lldb_ prefix.
zturner updated this object.
zturner edited the test plan for this revision. (Show Details)
zturner added reviewers: clayborg, jingham.
zturner added a subscriber: Unknown Object (MLST).
emaste added a subscriber: emaste.Nov 20 2014, 5:28 PM
clayborg accepted this revision.Nov 20 2014, 5:35 PM
clayborg edited edge metadata.

Lgtm

This revision is now accepted and ready to land.Nov 20 2014, 5:35 PM
zturner closed this revision.Nov 20 2014, 6:00 PM
zturner updated this revision to Diff 16467.

Closed by commit rL222495 (authored by @zturner).